fit_generator in keras v.2.2.4 and python 3.6.8 not working - python-3.x

fit_generator
works fine in:
Python 3.6.5
Keras 2.1.6
But doesn't in:
Python 3.6.8.
Keras 2.2.4
It gets stack forever in the 1st epoch (I can see it with verbose=1).
Did anyone experience this? If so, do you know how to make it work with the newer versions of python and keras?
Thank you

Related

How to fix numpy error in tensorboard in combination with mxnet?

I am trying to learn how to visualize layer activations in a convolutional neural network using MXNet and Tensorboard. When following the tutorial, however, I run into an error that seems to be related to numpy.
I followed this tutorial:
https://medium.com/apache-mxnet/mxboard-mxnet-data-visualization-2eed6ae31d2c
When I am in the conda prompt and enter the code:
tensorboard --logdir=./logs --host=127.0.0.1 --port=8888
The following error occurs:
ModuleNotFoundError: No module named 'numpy.core._multiarray_umath'
ImportError: numpy.core.multiarray failed to import
I thought I found a solution on the web that claimed that I have installed an older version of numpy (1.14). Which is kind of ironic because MXNet runs witht this older version only. So I am kind of confused...
In general, however, I am totally lost how to visualize the layer activation as others do. So if you know a different way how to do it, I am glad for some help!
Thanks a lot!
It looks like tensorboard is expecting a different version of numpy to the one installed. You could try upgrading the version of numpy (but this could potentially break MXNet functionality), or downgrading the version of tensorboard. As a safe choice, give this a go:
pip install --upgrade tensorflow==1.6.0
pip install --upgrade tensorboard==1.6.0

HTMLTestRunner not working in python 3.7.1

I am new in python automation.I am not able to use HTMLTestRunner in python 3.7.1. I am getting error
No module StringIO
I tried with multiple solution but none of them working.
If python 3.7.1 doesn't support HTMLTestRrunner then let me know how to downgrade python version in windows 10.

import tensorflow SyntaxError: invalid syntax

Using Virtualenv on Mac I have encountered the showing SyntaxError when I
import tensorflow
I tried many times uninstall but now working... please help me!
Tensorflow is not supported on Python 3.7. You'll need to use python3.6 or earlier.
async which was fine as a variable name in earlier versions of Python, is a keyword in Python 3.7. This is why it is failing to import.

Unable to run tensorlfow mnist_1.0_softmax.py

I have tried to tensorflow mnist tutorial on my mac. I used virtual environment with python 3.6.3 and matplotlib 2.1.0. When I ran the softmax code
python3 mnist_1.0_softmax.py
It gave an error like this
/User/.../Workspace/dl_tutorial/lib/python3.5/site-packages/matplotlib/backends/backend_macosx.py", line 19, in
from matplotlib.backends import _macosx RuntimeError: Python is not installed as a framework. The Mac OS X backend will not be able to function correctly if Python is not installed as a framework. See the Python documentation for more information on installing Python as a framework on Mac OS X. Please either reinstall Python as a framework, or try one of the other backends. If you are using (Ana)Conda please install python.app and replace the use of 'python' with 'pythonw'. See 'Working with Matplotlib on OSX' in the Matplotlib FAQ for more information.
How do I solve this? Do I need to reinstall python?
Looks like this is a similar problem to issue 21784641

Numpy and Scipy must be installed for TVRegDiag to work - aborting

I have installed Numpy and Scipy in an ubuntu EC2 instance. However, whenever I try to run any algorithm which has imported these modules, I keep on getting this one line of error Numpy and Scipy must be installed for TVRegDiag to work - aborting. What does this really mean.
it must be an ImportError according to the source code here http://math.lanl.gov/~rick/Software/TVDiff/tvregdiff.py
So, the python interpreter that you are using to launch your script is using some other python in the system which has no numpy or scipy.
#!/usr/bin/env python
do you have something like above in the first line of your code? And that's pointing to the right python version where you installed numpy/scipy?

Resources